[Gradle] Could not determine java version from 문제 해결

Could not determine java version from '9.0.4'

JDK9을 설치한 이후로 ./gradlew를 실행하면 해당 에러가 발생한다.
./gradle/wrapper/gradle-wrapper.properties파일을 열어보니 gradle 4.1버전을 사용중

4.3.1버전 이상으로 업데이트하면 문제가 해결된다.

#Sat Feb 24 17:55:43 KST 2018
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.3.1-all.zip

출처
gradle 홈페이지
=> 4.3버전 이상으로 업데이트 한 이후 해당 에러가 사라졌다고 한다.

Juyeong Lee

Read more posts by this author.